Build Notes

Unless you have redhat / fedora, you will need to build it. However, here are some great notes on doing just that


This site is not compltely accurate.

  • You Must install and operate out of the /opt/swinst for the builds to work
  • You Must use xml-security 1.3.0. The one specified is too old to build.
  • You Must specify apr-1-config. Plain old apr-config doesn't exist
Example automake configure command
$ ./configure 


  • enter the /opt/swinst/shibboleth-1.3/apache folder and edit the MakeFile to add a line to the CPP flag
CPPFLAGS = -I/usr/include/apr-1